const regex = /(?<=groups\/)(?<id>[0-9]+)|(?<=groups\/)(?<username>[a-zA-Z\.\_0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=groups\\\/)(?<id>[0-9]+)|(?<=groups\\\/)(?<username>[a-zA-Z\\.\\_0-9]+)', 'gm')
const str = `https://www.facebook.com/groups/164062097331207/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community/?ref=group_browse_new
https://www.facebook.com/groups/j2team.community.banned/?ref=group_browse_new`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}