re = /(src|href)="([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)"/
str = '<link rel="stylesheet" media="print" href="common/css/print.css?v=20111230">
<link rel="stylesheet" href="doc/docs.css">
<img src="common/logos/logo-mysql-110x57.png" alt="MySQL" width="110" height="57">
<script src="common/js/metrics/s_code_remote.js"></script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end