#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(src|href)="([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)""
Local $sString = "<link rel="stylesheet" media="print" href="common/css/print.css?v=20111230">" & @CRLF & _
"<link rel="stylesheet" href="doc/docs.css">" & @CRLF & _
"<img src="common/logos/logo-mysql-110x57.png" alt="MySQL" width="110" height="57">" & @CRLF & _
"<script src="common/js/metrics/s_code_remote.js"></script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")