const regex = /(src|href)="([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(src|href)="([0-9a-zA-Z_\\-\\\/]+\\.(css|js|png|jpg|jpeg)(\\?v=\\d+)?)"', 'g')
const str = `<link rel="stylesheet" media="print" href="common/css/print.css?v=20111230">
<link rel="stylesheet" href="doc/docs.css">
<img src="common/logos/logo-mysql-110x57.png" alt="MySQL" width="110" height="57">
<script src="common/js/metrics/s_code_remote.js"></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}