# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(src|href)=\"([0-9a-zA-Z_\-\/]+\.(css|js|png|jpg|jpeg)(\?v=\d+)?)\""
test_str = ("<link rel=\"stylesheet\" media=\"print\" href=\"common/css/print.css?v=20111230\">\n"
"<link rel=\"stylesheet\" href=\"doc/docs.css\">\n"
"<img src=\"common/logos/logo-mysql-110x57.png\" alt=\"MySQL\" width=\"110\" height=\"57\">\n"
"<script src=\"common/js/metrics/s_code_remote.js\"></script>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.