import Foundation
let pattern = #"^.*\s(\p{L}*,.*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Romin Romo Rosario, Salvedra Jimenez
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)