const regex = /^.*\s(\p{L}*,.*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\s(\\p{L}*,.*$)', 'g')
const str = `Romin Romo Rosario, Salvedra Jimenez
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);