use strict;
my $str = 'Romin Romo Rosario, Salvedra Jimenez
';
my $regex = qr/^.*\s(\p{L}*,.*$)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";