re = /\A\s*
(?: #########################################################################
# Matches against Australian postal addresses
# [<floor> <number>]
# [<unit type>] [<unit>] <house number> <street name> <street type>
# [<anything trailing>
#########################################################################
(?:(?P<c_level_type>level|lvl|floor|flr)\s*(?P<c_level_number>\w+),?\s*)? # Level (floor, etc)
\s*,?\s* # Optional comma
(?:(?P<c_unit_type>[[:alpha:]][\w-']*)?\s*)? # Type (suite, unit, etc)
(?:(?P<c_unit_number>[\w\.]*(?!\d))\s*[,\/]*\s*)? # Unit
(?P<c_house_number>\pN+[[:alpha:]]?(?:\s*[-\/\pP]\s*\pN+[[:alpha:]]?)*) # House number
\s*,?\s* # Optional comma
(?P<c_street_name>[\w-\s]*?) # Street name
\s+
\b(?P<c_street_type>fire\s*track|right\s*of\s*way|service\s*way|shopping\s*centre|state\s*highway|\w{2,})\b # Street type
(?:\s*\R+(?P<c_trailing>.+))? # Trailing data not captured
)
\s*\Z/xi
str = 'level 2, 100 smith avenue'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end