import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A\\s*\n"
+ " (?: #########################################################################\n"
+ " # Matches against Australian postal addresses\n"
+ " # [<floor> <number>]\n"
+ " # [<unit type>] [<unit>] <house number> <street name> <street type>\n"
+ " # [<anything trailing>\n"
+ " #########################################################################\n"
+ " (?:(?P<c_level_type>level|lvl|floor|flr)\\s*(?P<c_level_number>\\w+),?\\s*)? # Level (floor, etc)\n"
+ " \\s*,?\\s* # Optional comma\n"
+ " (?:(?P<c_unit_type>[[:alpha:]][\\w-']*)?\\s*)? # Type (suite, unit, etc)\n"
+ " (?:(?P<c_unit_number>[\\w\\.]*(?!\\d))\\s*[,\\/]*\\s*)? # Unit\n"
+ " (?P<c_house_number>\\pN+[[:alpha:]]?(?:\\s*[-\\/\\pP]\\s*\\pN+[[:alpha:]]?)*) # House number\n"
+ " \\s*,?\\s* # Optional comma\n"
+ " (?P<c_street_name>[\\w-\\s]*?) # Street name\n"
+ " \\s+\n"
+ " \\b(?P<c_street_type>fire\\s*track|right\\s*of\\s*way|service\\s*way|shopping\\s*centre|state\\s*highway|\\w{2,})\\b # Street type\n"
+ " (?:\\s*\\R+(?P<c_trailing>.+))? # Trailing data not captured\n"
+ " )\n"
+ " \\s*\\Z";
final String string = "level 2, 100 smith avenue";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}