#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xuis)\A\s*" & @CRLF & _
" (?: #########################################################################" & @CRLF & _
" # Matches against Australian postal addresses" & @CRLF & _
" # [<floor> <number>]" & @CRLF & _
" # [<unit type>] [<unit>] <house number> <street name> <street type>" & @CRLF & _
" # [<anything trailing>" & @CRLF & _
" #########################################################################" & @CRLF & _
" (?:(?P<c_level_type>level|lvl|floor|flr)\s*(?P<c_level_number>\w+),?\s*)? # Level (floor, etc)" & @CRLF & _
" \s*,?\s* # Optional comma" & @CRLF & _
" (?:(?P<c_unit_type>[[:alpha:]][\w-']*)?\s*)? # Type (suite, unit, etc)" & @CRLF & _
" (?:(?P<c_unit_number>[\w\.]*(?!\d))\s*[,\/]*\s*)? # Unit" & @CRLF & _
" (?P<c_house_number>\pN+[[:alpha:]]?(?:\s*[-\/\pP]\s*\pN+[[:alpha:]]?)*) # House number" & @CRLF & _
" \s*,?\s* # Optional comma" & @CRLF & _
" (?P<c_street_name>[\w-\s]*?) # Street name" & @CRLF & _
" \s+" & @CRLF & _
" \b(?P<c_street_type>fire\s*track|right\s*of\s*way|service\s*way|shopping\s*centre|state\s*highway|\w{2,})\b # Street type" & @CRLF & _
" (?:\s*\R+(?P<c_trailing>.+))? # Trailing data not captured" & @CRLF & _
" )" & @CRLF & _
" \s*\Z"
Local $sString = "level 2, 100 smith avenue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")