# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
\A\s*
(?: #########################################################################
# Matches against Australian postal addresses
# [<floor> <number>]
# [<unit type>] [<unit>] <house number> <street name> <street type>
# [<anything trailing>
#########################################################################
(?:(?P<c_level_type>level|lvl|floor|flr)\s*(?P<c_level_number>\w+),?\s*)? # Level (floor, etc)
\s*,?\s* # Optional comma
(?:(?P<c_unit_type>[[:alpha:]][\w-']*)?\s*)? # Type (suite, unit, etc)
(?:(?P<c_unit_number>[\w\.]*(?!\d))\s*[,\/]*\s*)? # Unit
(?P<c_house_number>\pN+[[:alpha:]]?(?:\s*[-\/\pP]\s*\pN+[[:alpha:]]?)*) # House number
\s*,?\s* # Optional comma
(?P<c_street_name>[\w-\s]*?) # Street name
\s+
\b(?P<c_street_type>fire\s*track|right\s*of\s*way|service\s*way|shopping\s*centre|state\s*highway|\w{2,})\b # Street type
(?:\s*\R+(?P<c_trailing>.+))? # Trailing data not captured
)
\s*\Z
"""
test_str = "level 2, 100 smith avenue"
matches = re.finditer(regex, test_str, re.VERBOSE | re.UNICODE | re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.