import Foundation
let pattern = #"^((s?ftp:\/\/)([\w]+)@([\w-.]+)(\/[\w-]+){3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20HD%20%5bBlu-ray%5d.mp4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}