const regex = /^((s?ftp:\/\/)([\w]+)@([\w-.]+)(\/[\w-]+){3})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((s?ftp:\\\/\\\/)([\\w]+)@([\\w-.]+)(\\\/[\\w-]+){3})', '')
const str = `sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20HD%20%5bBlu-ray%5d.mp4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}