#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((s?ftp:\/\/)([\w]+)@([\w-.]+)(\/[\w-]+){3})"
Local $sString = "sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20FHD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20HD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20FHD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20HD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20FHD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20HD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20FHD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20HD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20FHD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20HD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20FHD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20HD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20FHD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20HD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20FHD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20HD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20FHD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20HD.mkv" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20FHD%20%5bBlu-ray%5d.mp4" & @CRLF & _
"sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20HD%20%5bBlu-ray%5d.mp4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")