$re = '/^((s?ftp:\/\/)([\w]+)@([\w-.]+)(\/[\w-]+){3})/';
$str = 'sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2001%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2002%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2003%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2004%20vostfr%20HD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20FHD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%2010%20bits%20HD.mkv
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20FHD%20%5bBlu-ray%5d.mp4
sftp://kura@family-desuyo.moe/home/dedie/Anime/Planetarian_BD/%5bManga%20Family%5d%20Planetarian%20Chiisana%20Hoshi%20no%20Yume%20-%2005%20vostfr%20HD%20%5bBlu-ray%5d.mp4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);