$re = '/\d{6}.\S{1,3}/m';
$str = '180906.T
180906.T7';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;