# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{6}.\S{1,3}//gm;t' <<< "180906.T
180906.T7"