const regex = /\d{6}.\S{1,3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{6}.\\S{1,3}', 'gm')
const str = `180906.T
180906.T7`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);