# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?:\/\/)?([a-z0-9]+\.)*[a-z0-9]+\.[a-z]+$"
test_str = ("http://www.sample.com\n"
"https://www.sample.com\n"
"https://www.sample.com#\n"
"http://www.sample.com/xyz\n"
"http://www.sample.com/#xyz\n"
"www.sample.com\n"
"www.sample.com/xyz/#/xyz\n"
"sample.com\n"
"sample.com?name=foo\n"
"http://www.sample.com#xyz\n"
"http://www.sample.c\n"
"sample.com\n"
"http://sample.com\n"
"https://sample.com\n"
"https://www.sample.com\n"
"https://sub.domain.com\n"
"https://sub.domain.com/\n"
"https://sub.domain.com/path\n"
"https://sub.domain.com/path/another\n"
"https://sub.domain.com?qs\n"
"https://sub.domain.com?q=search\n"
"https://sub.domain.com/test/?qs")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.