import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/)?([a-z0-9]+\\.)*[a-z0-9]+\\.[a-z]+$";
final String string = "http://www.sample.com\n"
+ "https://www.sample.com\n"
+ "https://www.sample.com#\n"
+ "http://www.sample.com/xyz\n"
+ "http://www.sample.com/#xyz\n"
+ "www.sample.com\n"
+ "www.sample.com/xyz/#/xyz\n"
+ "sample.com\n"
+ "sample.com?name=foo\n"
+ "http://www.sample.com#xyz\n"
+ "http://www.sample.c\n"
+ "sample.com\n"
+ "http://sample.com\n"
+ "https://sample.com\n"
+ "https://www.sample.com\n"
+ "https://sub.domain.com\n"
+ "https://sub.domain.com/\n"
+ "https://sub.domain.com/path\n"
+ "https://sub.domain.com/path/another\n"
+ "https://sub.domain.com?qs\n"
+ "https://sub.domain.com?q=search\n"
+ "https://sub.domain.com/test/?qs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}