const regex = /^(https?:\/\/)?([a-z0-9]+\.)*[a-z0-9]+\.[a-z]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/)?([a-z0-9]+\\.)*[a-z0-9]+\\.[a-z]+$', 'gm')
const str = `http://www.sample.com
https://www.sample.com
https://www.sample.com#
http://www.sample.com/xyz
http://www.sample.com/#xyz
www.sample.com
www.sample.com/xyz/#/xyz
sample.com
sample.com?name=foo
http://www.sample.com#xyz
http://www.sample.c
sample.com
http://sample.com
https://sample.com
https://www.sample.com
https://sub.domain.com
https://sub.domain.com/
https://sub.domain.com/path
https://sub.domain.com/path/another
https://sub.domain.com?qs
https://sub.domain.com?q=search
https://sub.domain.com/test/?qs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}