$re = '/^(https?:\/\/)?([a-z0-9]+\.)*[a-z0-9]+\.[a-z]+$/m';
$str = 'http://www.sample.com
https://www.sample.com
https://www.sample.com#
http://www.sample.com/xyz
http://www.sample.com/#xyz
www.sample.com
www.sample.com/xyz/#/xyz
sample.com
sample.com?name=foo
http://www.sample.com#xyz
http://www.sample.c
sample.com
http://sample.com
https://sample.com
https://www.sample.com
https://sub.domain.com
https://sub.domain.com/
https://sub.domain.com/path
https://sub.domain.com/path/another
https://sub.domain.com?qs
https://sub.domain.com?q=search
https://sub.domain.com/test/?qs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);