// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"Lead_Owner_Email__c":"(?<leadOwner>.*?)".*?"School__c":"(?<school>.*?)".*?"Level__c":"(?<level>.*?)""#).unwrap();
let string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Lead\",\"url\":\"/services/data/v43.0/sobjects/Lead/00Q1300001TDlooEAD\"},\"Id\":\"00Q1300001TDlooEAD\",\"Lead_Owner_Email__c\":\"mgq23@drexel.edu\",\"InquiryProgram__r\":{\"attributes\":{\"type\":\"Program__c\",\"url\":\"/services/data/v43.0/sobjects/Program__c/a03a000000FcFl1AAF\"},\"School__c\":\"NH\",\"Level__c\":\"Graduate\"}}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}