#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"Lead_Owner_Email__c":"(?<leadOwner>.*?)".*?"School__c":"(?<school>.*?)".*?"Level__c":"(?<level>.*?)""
Local $sString = "{"searchRecords":[{"attributes":{"type":"Lead","url":"/services/data/v43.0/sobjects/Lead/00Q1300001TDlooEAD"},"Id":"00Q1300001TDlooEAD","Lead_Owner_Email__c":"mgq23@drexel.edu","InquiryProgram__r":{"attributes":{"type":"Program__c","url":"/services/data/v43.0/sobjects/Program__c/a03a000000FcFl1AAF"},"School__c":"NH","Level__c":"Graduate"}}]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")