using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Lead_Owner_Email__c"":""(?<leadOwner>.*?)"".*?""School__c"":""(?<school>.*?)"".*?""Level__c"":""(?<level>.*?)""";
string input = @"{""searchRecords"":[{""attributes"":{""type"":""Lead"",""url"":""/services/data/v43.0/sobjects/Lead/00Q1300001TDlooEAD""},""Id"":""00Q1300001TDlooEAD"",""Lead_Owner_Email__c"":""mgq23@drexel.edu"",""InquiryProgram__r"":{""attributes"":{""type"":""Program__c"",""url"":""/services/data/v43.0/sobjects/Program__c/a03a000000FcFl1AAF""},""School__c"":""NH"",""Level__c"":""Graduate""}}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}