const regex = /"Lead_Owner_Email__c":"(?<leadOwner>.*?)".*?"School__c":"(?<school>.*?)".*?"Level__c":"(?<level>.*?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"Lead_Owner_Email__c":"(?<leadOwner>.*?)".*?"School__c":"(?<school>.*?)".*?"Level__c":"(?<level>.*?)"', 'gm')
const str = `{"searchRecords":[{"attributes":{"type":"Lead","url":"/services/data/v43.0/sobjects/Lead/00Q1300001TDlooEAD"},"Id":"00Q1300001TDlooEAD","Lead_Owner_Email__c":"mgq23@drexel.edu","InquiryProgram__r":{"attributes":{"type":"Program__c","url":"/services/data/v43.0/sobjects/Program__c/a03a000000FcFl1AAF"},"School__c":"NH","Level__c":"Graduate"}}]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}