// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)rr\d---sn-\w{8}.googlevideo.com").unwrap();
let string = "||rr3---sn-hp57yne7.googlevideo.com^$important
||rr3---sn-oguelnlz.googlevideo.com^$important
||rr5---sn-hp57knd6.googlevideo.com^$important";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}