$re = '/rr\d---sn-\w{8}.googlevideo.com/m';
$str = '||rr3---sn-hp57yne7.googlevideo.com^$important
||rr3---sn-oguelnlz.googlevideo.com^$important
||rr5---sn-hp57knd6.googlevideo.com^$important';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);