package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)rr\d---sn-\w{8}.googlevideo.com`)
var str = `||rr3---sn-hp57yne7.googlevideo.com^$important
||rr3---sn-oguelnlz.googlevideo.com^$important
||rr5---sn-hp57knd6.googlevideo.com^$important`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}