re = /rr\d---sn-\w{8}.googlevideo.com/m
str = '||rr3---sn-hp57yne7.googlevideo.com^$important
||rr3---sn-oguelnlz.googlevideo.com^$important
||rr5---sn-hp57knd6.googlevideo.com^$important'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end