re = /^(?<streetname>\d*[\p{L}\d '\/.\-]+)[,\s]+(?<housenumber>\d+)\s*(?<ext>[\p{L}\d\-\/'"() ]*)$/i
str = 'Spieringstraat 87-89'
# Print the match result
str.match(re) do |match|
puts match.to_s
end