$re = '/^(?<streetname>\d*[\p{L}\d \'\/.\-]+)[,\s]+(?<housenumber>\d+)\s*(?<ext>[\p{L}\d\-\/\'"() ]*)$/iu';
$str = 'Spieringstraat 87-89';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);