using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<streetname>\d*[\p{L}\d '\/.\-]+)[,\s]+(?<housenumber>\d+)\s*(?<ext>[\p{L}\d\-\/'""() ]*)$";
string input = @"Spieringstraat 87-89";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}