import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<streetname>\\d*[\\p{L}\\d '\\/.\\-]+)[,\\s]+(?<housenumber>\\d+)\\s*(?<ext>[\\p{L}\\d\\-\\/'\"() ]*)$";
final String string = "Spieringstraat 87-89";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}