import Foundation
let pattern = #"(?:\w*|\(.*\))(\(class=(\".*\")\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+image(class="sumup-illustration, vector" src="/sumup-x-debitoor-guide/final_illustration_sumup_en.svg" alt="Meet a better way to stay on top of your SumUp payments")
+image(class="classTest1, classTest2, classTest3, classTest4")
+grid__item("md-4", "md-vertical-4x-gutter", "xs-first", "md-last")(class="accent, button, link")
+button(class="red")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)