$re = '/(?:\w*|\(.*\))(\(class=(\".*\")\))/m';
$str = '+image(class="sumup-illustration, vector" src="/sumup-x-debitoor-guide/final_illustration_sumup_en.svg" alt="Meet a better way to stay on top of your SumUp payments")
+image(class="classTest1, classTest2, classTest3, classTest4")
+grid__item("md-4", "md-vertical-4x-gutter", "xs-first", "md-last")(class="accent, button, link")
+button(class="red")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);