using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\w*|\(.*\))(\(class=(\"".*\"")\))";
string input = @"+image(class=""sumup-illustration, vector"" src=""/sumup-x-debitoor-guide/final_illustration_sumup_en.svg"" alt=""Meet a better way to stay on top of your SumUp payments"")
+image(class=""classTest1, classTest2, classTest3, classTest4"")
+grid__item(""md-4"", ""md-vertical-4x-gutter"", ""xs-first"", ""md-last"")(class=""accent, button, link"")
+button(class=""red"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}