import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\w*|\\(.*\\))(\\(class=(\\\".*\\\")\\))";
final String string = "+image(class=\"sumup-illustration, vector\" src=\"/sumup-x-debitoor-guide/final_illustration_sumup_en.svg\" alt=\"Meet a better way to stay on top of your SumUp payments\") \n"
+ "+image(class=\"classTest1, classTest2, classTest3, classTest4\") \n"
+ "+grid__item(\"md-4\", \"md-vertical-4x-gutter\", \"xs-first\", \"md-last\")(class=\"accent, button, link\") \n"
+ "+button(class=\"red\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}