# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[.|@](company.(fr|com|co.uk)|company2.(fr|com|co.uk)|company3.com)$"
test_str = ("arnaud@company.fr\n"
"arnaud@company.co.uk\n"
"arnaud@company.com\n"
"arnaud_company@test.com\n"
"companyarnaud@nope.de\n"
"arnaud@company.test.com\n"
"arnaud@test-company.com\n"
"arnaud@company2.fr\n"
"arnadu@test.company2.fr\n"
"arnaud@company.tests.fr\n"
"arnaud@company2.co.uk\n"
"arnaud@company3.com\n"
"arnaud@company3.com.test.com\n"
"arnaud@company.fr.com\n"
"arnaud@test.company3.com\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.