$re = '/[.|@](company.(fr|com|co.uk)|company2.(fr|com|co.uk)|company3.com)$/mi';
$str = 'arnaud@company.fr
arnaud@company.co.uk
arnaud@company.com
arnaud_company@test.com
companyarnaud@nope.de
arnaud@company.test.com
arnaud@test-company.com
arnaud@company2.fr
arnadu@test.company2.fr
arnaud@company.tests.fr
arnaud@company2.co.uk
arnaud@company3.com
arnaud@company3.com.test.com
arnaud@company.fr.com
arnaud@test.company3.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);