import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[.|@](company.(fr|com|co.uk)|company2.(fr|com|co.uk)|company3.com)$";
final String string = "arnaud@company.fr\n"
+ "arnaud@company.co.uk\n"
+ "arnaud@company.com\n"
+ "arnaud_company@test.com\n"
+ "companyarnaud@nope.de\n"
+ "arnaud@company.test.com\n"
+ "arnaud@test-company.com\n"
+ "arnaud@company2.fr\n"
+ "arnadu@test.company2.fr\n"
+ "arnaud@company.tests.fr\n"
+ "arnaud@company2.co.uk\n"
+ "arnaud@company3.com\n"
+ "arnaud@company3.com.test.com\n"
+ "arnaud@company.fr.com\n"
+ "arnaud@test.company3.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}