#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[.|@](company.(fr|com|co.uk)|company2.(fr|com|co.uk)|company3.com)$"
Local $sString = "arnaud@company.fr" & @CRLF & _
"arnaud@company.co.uk" & @CRLF & _
"arnaud@company.com" & @CRLF & _
"arnaud_company@test.com" & @CRLF & _
"companyarnaud@nope.de" & @CRLF & _
"arnaud@company.test.com" & @CRLF & _
"arnaud@test-company.com" & @CRLF & _
"arnaud@company2.fr" & @CRLF & _
"arnadu@test.company2.fr" & @CRLF & _
"arnaud@company.tests.fr" & @CRLF & _
"arnaud@company2.co.uk" & @CRLF & _
"arnaud@company3.com" & @CRLF & _
"arnaud@company3.com.test.com" & @CRLF & _
"arnaud@company.fr.com" & @CRLF & _
"arnaud@test.company3.com" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")