import Foundation
let pattern = #"(?:\n|\s$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
★★★★★★: Nearl the Radiant Knight (Limited)
★★★★★★: Flametail / Rosmotis
★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)
★★★★★: Wild Mane
★★★★★: Honeyberry
★★★★: Pudding [limited]
★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)
★★★★★: Corroserum (50% in 5* Operators)
★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)