const regex = /(?:\n|\s$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\n|\\s$)', 'gm')
const str = `★★★★★★: Nearl the Radiant Knight (Limited)
★★★★★★: Flametail / Rosmotis
★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)
★★★★★: Wild Mane
★★★★★: Honeyberry
★★★★: Pudding [limited]
★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)
★★★★★: Corroserum (50% in 5* Operators)
★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}