$re = '/(?:\n|\s$)/m';
$str = '★★★★★★: Nearl the Radiant Knight (Limited)
★★★★★★: Flametail / Rosmotis
★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)
★★★★★: Wild Mane
★★★★★: Honeyberry
★★★★: Pudding [limited]
★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)
★★★★★: Corroserum (50% in 5* Operators)
★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);