import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\n|\\s$)";
final String string = "★★★★★★: Nearl the Radiant Knight (Limited)\n"
+ "★★★★★★: Flametail / Rosmotis\n"
+ "★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)\n"
+ "★★★★★: Wild Mane\n"
+ "★★★★★: Honeyberry\n"
+ "★★★★: Pudding [limited]\n"
+ "★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)\n"
+ "★★★★★: Corroserum (50% in 5* Operators)\n"
+ "★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}