re = /((?![\u0621-\u064A\u0660-\u0669 ]).)/mi
str = 'مع فيزيتا اختر بين أفضل عروض اسنان في السعودية،اختر المنطقة الأقرب لك، قارن بين اسعار العروض الطبية واحجز موعدك بسهولة'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end