import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?![\\u0621-\\u064A\\u0660-\\u0669 ]).)";
final String string = "مع فيزيتا اختر بين أفضل عروض اسنان في السعودية،اختر المنطقة الأقرب لك، قارن بين اسعار العروض الطبية واحجز موعدك بسهولة";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}