const regex = /((?![\u0621-\u064A\u0660-\u0669 ]).)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?![\\u0621-\\u064A\\u0660-\\u0669 ]).)', 'gmi')
const str = `مع فيزيتا اختر بين أفضل عروض اسنان في السعودية،اختر المنطقة الأقرب لك، قارن بين اسعار العروض الطبية واحجز موعدك بسهولة`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}